OpenBSD » History » Version 2
Willy Manga, 03/26/2025 01:05 AM
1 | 1 | Willy Manga | h1. OpenBSD |
---|---|---|---|
2 | |||
3 | Everything we need to know when it comes to this amazing OS. |
||
4 | |||
5 | |||
6 | h2. Typical layout |
||
7 | |||
8 | 2 | Willy Manga | Caution: For any upgrade /usr must have at least 1.1G available space!. |
9 | |||
10 | 1 | Willy Manga | <pre> |
11 | a / |
||
12 | b swap |
||
13 | |||
14 | d: 1000M 3220512 4.2BSD 2048 16384 1 # /tmp |
||
15 | e: 2000M 4932608 4.2BSD 2048 16384 1 # /var |
||
16 | 2 | Willy Manga | f: 4000.0M 7479264 4.2BSD 2048 16384 1 # /usr |
17 | 1 | Willy Manga | g: 2366.5M 13720480 4.2BSD 2048 16384 1 # /usr/local |
18 | h: 2227.0M 18567040 4.2BSD 2048 16384 1 # /usr/src |
||
19 | i: 5478.0M 23127904 4.2BSD 2048 16384 1 # /usr/obj |
||
20 | j: 1000.1M 34346816 4.2BSD 2048 16384 1 # /home |
||
21 | k: 2000M 4932608 4.2BSD 2048 16384 1 # /var/log |
||
22 | ~ |
||
23 | </pre> |
||
24 | 2 | Willy Manga | |
25 | After genuine install, how it looks like |
||
26 | |||
27 | <pre><code class="shell"> |
||
28 | rr01# df -h |
||
29 | Filesystem Size Used Avail Capacity Mounted on |
||
30 | /dev/sd0a 1.6G 100M 1.4G 7% / |
||
31 | /dev/sd0j 989M 2.0K 940M 1% /home |
||
32 | /dev/sd0d 989M 8.0K 940M 1% /tmp |
||
33 | /dev/sd0f 2.3G 1.4G 728M 67% /usr |
||
34 | /dev/sd0g 2.2G 144K 2.1G 1% /usr/local |
||
35 | /dev/sd0i 3.9G 2.0K 3.7G 1% /usr/obj |
||
36 | /dev/sd0h 2.1G 2.0K 2.0G 1% /usr/src |
||
37 | /dev/sd0e 1.9G 13.9M 1.8G 1% /var |
||
38 | /dev/sd0k 1.9G 24.0K 1.8G 1% /var/log |
||
39 | </code></pre> |
||
40 | |||
41 | 1 | Willy Manga | |
42 | |||
43 | h2. Libvirt |
||
44 | |||
45 | |||
46 | To install on a headless debian KVM server (with virt-install ) ... |
||
47 | |||
48 | From https://r0tty.org/blog/headless-kvm-openbsd-install/ |
||
49 | |||
50 | * use a dedicated folder (e.g /tmp/lab ) |
||
51 | * download the install file (iso file) e.g cd72.iso or install72.iso |
||
52 | * install @growisofs@ (and @genisoimage@) |
||
53 | * create a file where you will insert instructions for openbsd to use the serial console @echo 'set tty com0' > boot.conf@ |
||
54 | * update the content of boot.conf with @growisofs -M cd72.iso -l -R -graft-points /etc/boot.conf=boot.conf@ |
||
55 | <pre> |
||
56 | root@man021-truserv-jhb1-001 /tmp/lab $ growisofs -M bsd74.iso -l -R -graft-points /etc/boot.conf=boot.conf |
||
57 | Executing 'genisoimage -C 16,308992 -M /dev/fd/3 -l -R -graft-points /etc/boot.conf=boot.conf | builtin_dd of=bsd74.iso obs=32k seek=19312' |
||
58 | I: -input-charset not specified, using utf-8 (detected in locale settings) |
||
59 | Rock Ridge signatures found |
||
60 | Total translation table size: 0 |
||
61 | Total rockridge attributes bytes: 2429 |
||
62 | Total directory bytes: 8192 |
||
63 | Path table size(bytes): 48 |
||
64 | Max brk space used 0 |
||
65 | 309172 extents written (603 MB) |
||
66 | builtin_dd: 192*2KB out @ average infx1352KBps |
||
67 | bsd74.iso: copying volume descriptor(s) |
||
68 | </pre> |
||
69 | * your iso will be updated |
||
70 | |||
71 | * launch your installation |
||
72 | |||
73 | <pre> |
||
74 | virt-install -n openbsd0 --memory 512 --vcpus 1 --cdrom /var/lib/libvirt/images/cd72.1.iso --os-variant openbsd7.0 --disk size=10 --network bridge=br899 --graphics none --console pty,target_type=serial |
||
75 | </pre> |
||
76 | |||
77 | * it seems for pfSense, you should check this https://www.reddit.com/r/sysadmin/comments/46l9jy/installing_pfsense_on_kvm_cliheadless/ |